My 580EX II Sometimes Does Not Fire

I thought my 580EX II has gone south on me when it fails to fire sometimes. And nothing can be more dismal than a flash that doesn’t fire when you expect it to work the most – during an event coverage.

Just this week, my 580EX II speedlite started to act queer, sometimes fires, sometimes doesn’t. I have to take it off the hotshoe and replace it before it fires again. Then again, sometimes it still fails to work. It was exasperating especially when I’m covering some event and a (supposedly) perfect picture comes out dark because of a speedlite misfire.

The first time it happened, the battery was almost already spent. So I thought it was a case of low power supply. But even after a fresh recharge the same thing happens.

The Solution

My external flash does not fire sometimes

The thought of having to part with my gear for a day or two is kind of difficult and I fear that it might happen if the symptoms continue as I really have to send it in for the Canon experts to check out. Luckily, I got to ask some questions at the perfect place that often has perfect answers – the google search page.

Turns out, it’s a case of a contact problem. Some sort of cleaning the parts that gets to make connections at the hotshoe. That is, cleaning involves both the hotshoe on the camera and the contacts at the speedlite.

And what do I use to clean these thingies? An eraser!

That was no suprise to me as I have some experience in this area. I once cleaned up the memory cards of a cpu using an eraser. When I put back the ‘erased’ memory cards in place, the computer came back to life.

So, what I did was to rub the eraser on the hotshoe surfaces as well as the contact surfaces on the speedlite. After doing so, I wiped off the excess ‘burnt’ rubber of the contacts with a piece of clean cloth. And voila! Everything was back to normal.

I still don’t know why I need to use an eraser to clean it up. If it’s just dust, a little blowing off would probably do. If an eraser is needed, perhaps the dirt that got stuck on the contacts must be of the stubborn type.

Another Solution

Another reason a speedlite may fail to fire is a wobbly or loose coupling at the hotshoe. Here’s a video I found that explains it all.

P.S. If you haven’t checked out my post about the Canon 580EX II, please read it. I’ve included there a few videos about the proper use of the 580EX II.


I posted this as soon as I completed the cleaning and the camera began working nicely.

The pessimist in me however tells me to observe the gear a few more days before rejoicing at having found a solution to the speedlite problem. Well, l’ll definitely make an update to this post, whatever happens in a few days.